结合均线战法+买卖点提示

时间:2019-11-13 15:44:57 来源:操盘手公式 作者:结合均线战法+买卖点提示

    以下是结合均线战法+买卖点提示 个人修改使用。经测试不错 附带指标用法说明(无源码的请下载附件导入)
 
    结合均线战法+买卖点提示  个人修改使用。经测试不错    附带指标用法说明!
 
    杀手系统即3日均线、13日均线、21日均线组合系统的简称。1杀手系统视角独特,操作简便,实战性强。该指标选择的买卖点只是组合系统的一部分,该系统有3个以上买卖点:如底部形态之"启动1"和"侠拉升2";即将拉升的启动形态之"黑客点击"和"侠拉升2";中途的整理形态之"走四方"和"浪子回头";顶部形态之"见好就收"和"独上高楼";其他形态还有"均上攻"、"三进场"、"梅上升中继"等。该指标选用了以上的8种,用来实战也足够了。
 
    1、红启动
 
    形态特征:3日均线由下降趋于走平。股价从下向上突破 3日均线,并且在3日均线上企稳,这根站在3日均线上的阳线称之为"启动1"。启动1是35均线的第一买点,也是行情最初启动点。
 
    2、蚂转强
 
    形态特征:两条略微向右下方倾斜的主均线相距很近或基本持平。股价踏上3日均线后,以连续上攻的小阳线缓步盘升,把股价轻松地送上21日均线。这几根持续上升的小阳线称之为"侠拉升2"。"侠拉升2"的出现,是股价见底,开始转强的标志。
 
    3、黑拉升1
 
    形态特征:股价有效突破21日均线后开始回落,但在21日均线附近获得支撑,如果K线收阴,回落的股价恰好落在3日均线与21日均线的结点处,即"黑客点击"形态成立,是即将拉升的标志之一。"黑客点击"出现以后,应密切关注均线系统以及量能的变化,一旦发现放量上攻,要毫不犹豫地进场为庄家抬轿,当股价有了20%左右的涨幅以后,若发现上攻力度减弱,3日均线有走软迹象,应先出局观望。
 
    4、侠拉升2
 
    形态特征:股价经过长期下跌或充分调整以后,21日均线基本处于水平状态。股价沿着3日均线爬至21日均线附近进行窄幅整理。在3日均线上穿21日均线之日,如果股价携量上攻,形态即告成立。把站在"右上角"结点处的那根阳线称之为"侠拉升2",是即将拉升的标志之二。
 
    5、梅上升中继
 
    形态特征:3日均线向上穿越21日均线以后,股价滞涨回落,3日均线弱势下叉13日均线,随着股价的止跌企稳,3日均线开始勾头向上二次穿越13日均线,我们把在主均线之上的3日均线金叉穿越13日均线,称之为"梅上升中继",属上升中继形态。
 
    6、均上攻
 
    形态特征:前期13日均线顺势上穿21日均线。13日均线下穿再上穿21日均线的过程,就是"均上攻"。"均上攻"的完成,标志着股价开始走强,此后均线系统构成的多头排列,支持股价延续上行趋势,后市必有一波上攻行情。
 
    7、三进场
 
    形态特征:股价长期在底部区域昏昏欲睡,均线系统呈胶合状态或间距极小的多头或空头排列,股价始终在三线附近小幅波动,时间一般持续半年左右。此时如出现一阳穿三线或股价在三线上揭竿而起,"三进场"形态即告成立,那将是绝佳进场时机。
 
    杀手系列公式代码如下:
 
    EMA3:EMA(C,3),COLORWHITE,LINETHICK2;
 
    EMA13:EMA(C,13),COLORYELLOW;
 
    EMA21:EMA(C,21),COLORFF00FF;
 
    EMA55:EMA(C,55),COLORGREEN;
 
    AR1:=EMA21>EMA13 AND EMA13>EMA3;
 
    AR2:=BARSLAST((C-EMA3)/EMA3*100<-6);
 
    AR3:=EMA3>=REF(EMA3,2);
 
    AR4:=COUNT(CROSS(C,EMA3),AR2)=1;
 
    AR5:=AR1 AND AR2 AND AR3 AND AR4;
 
    AR6:=AR5 AND FILTER(AR5,10);
 
    DRAWTEXT(AR6,L-0.09,'红启动'),COLORYELLOW;
 
    {STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;}
 
    {STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}
 
    BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
 
    BR2:=ABS((EMA3-EMA13)+(EMA13-EMA21))/C<0.2;
 
    BR3:=C>EMA21 AND (REF(C,1)<REF(EMA21,1) OR REF(C,2)<REF(EMA21,2) OR REF(C,3)<REF(EMA21,3) OR REF(C,4)<REF(EMA21,4) OR REF
 
    (C,5)<REF(EMA21,5));
 
    BR4:=BR1 AND BR2 AND BR3;
 
    DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'蚂转强'),COLOR00C5FF;
 
    STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
 
    {STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;}
 
    CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
 
    CR2:=V>MA(V,5)*0.6;
 
    CR3:=COUNT(CROSS(EMA3,EMA21),3)=1;
 
    CR4:=ABS(EMA13-EMA21)/EMA21<0.03;
 
    CR5:=EMA21<=EMA55 AND EMA21>=REF(EMA21,1);
 
    CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
 
    {STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;}
 
    {STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}
 
    DRAWTEXT(CR6,L-0.09,'侠拉升2'),COLORF00FF0;
 
    DR1:=EMA3>EMA13 AND EMA13<EMA21;
 
    DR2:=BARSLAST(CROSS(C,EMA21) );
 
    DR3:=H=HHV(H,DR2);
 
    DR4:=BARSLAST(DR3);
 
    DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA21 AND BETWEEN((C-EMA21)/EMA21,0,0.02),DR4)=1;
 
    DR6:=C>REF(C,1) ;
 
    DR7:= DR1 AND DR5 AND DR6 ;
 
    DR8:=DR7 AND FILTER(DR7 ,10);
 
    DRAWTEXT(DR8,L-0.09,'黑拉升1'),COLORD6BA63;
 
    {STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;}
 
    STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;
 
    ER:=BARSLAST(REF(CROSS(EMA21,EMA13),1)) AND CROSS(EMA13,EMA21);
 
    DRAWTEXT(ER,L-0.09,'均上攻'),COLOR0099FF;
 
    {STICKLINE(ER,H,L,0.5,1),COLOR0099FF;}
 
    {STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
 
    FR:=BARSLAST(REF(CROSS(EMA13,EMA3),1)) AND CROSS(EMA3,EMA13);
 
    DRAWTEXT(FR,L-0.09,'梅上升中继'),COLORWHITE;
 
    STICKLINE(FR,H,L,0.5,1),COLORWHITE;
 
    {STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
 
    GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,3,24),0,5) );
 
    GR2:=EMA3>EMA13 AND EMA13>EMA21 AND EMA3>REF(EMA3,1);
 
    GR3:=COUNT("BIAS.BIAS2"(6,3,24)>10 AND H=HHV(H,GR1),GR1);
 
    GR4:=H=HHV(H,GR1);
 
    GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
 
    GR6:=GR2 AND GR3 AND GR4;
 
    GR7:=GR2 AND GR3 AND GR4 AND GR5;
 
    DRAWTEXT(GR6 AND GR7,H+0.3,'见逃顶'),COLOR00FF00;
 
    STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
 
    HR2:=EMA3>=REF(EMA3,3) AND EMA13>=REF(EMA13,1) AND EMA21>=REF(EMA21,1) AND CROSS(C,EMA3) AND CROSS(C,EMA13) AND CROSS
 
    (C,EMA21){ AND CROSS(C,EMA55)};
 
    DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'三进场! '),COLORFFC8FF;
 
    {STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
 
    STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;};
 
    MA1:MA(CLOSE,34),COLORBLUE;
 
    K1:=(C+H+L)/3;
 
    D1:=MA(K1,4);
 
    高:=REF(HHV(H,80),3);
 
    低:=REF(LLV(L,80),3);
 
    顶点:REFDATE(高,DATE),COLORGREEN,LINETHICK3;
 
    低点:REFDATE(低,DATE),COLORRED,LINETHICK2;
 
    AA05:MA(C,5),LINETHICK3,COLOR00CCFF;
 
    BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
 
    IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORRED;
 
    DRAWTEXT(REF(C,1)>D1 AND C<D1 AND D1>REF(D1,1),H*1.02,'卖'),COLORGREEN;
 
    DRAWTEXT(REF(C,1)<D1 AND C>D1 AND D1<REF(D1,1),L*0.98,'买'),COLORRED;

结合均线战法+买卖点提示
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告