飞狐我傻瓜我怕谁指标公式

时间:2020-02-16 19:54:37 来源:飞狐公式 作者:飞狐我傻瓜我怕谁指标公式

    以下是飞狐我傻瓜我怕谁指标公式
 
    input: N(14,1,20),M(6,1,10);
 
    DRAWGBK((DATE > 0),COLORRGB(0,33,0),COLORRGB(0,33,0),1);
 
    {-----------------------☆功能开关------------------------}
 
    TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
 
    HD :=HIGH-REF(HIGH,1);
 
    LD :=REF(LOW,1)-LOW;
 
    DMP:=EMA(IF(HD>0&&HD>LD,HD,0),N);
 
    DMM:=EMA(IF(LD>0&&LD>HD,LD,0),N);
 
    PDI: DMP*100/TR1,LINETHICK,PRECISION2,COLORRED;
 
    MDI: DMM*100/TR1,LINETHICK,PRECISION2,COLORCYAN;
 
    ADX: EMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),LINETHICK,PRECISION2,COLORWHITE;
 
    ADXR:EMA(ADX,M),LINETHICK,PRECISION2,COLORYELLOW;
 
    {信号}
 
    {一,MDI必须在下方,PDI在下方无效,二、PDI趋势向上。三、必须在PDI及MDI中间金叉 }
 
    T1:=CROSS(ADX,ADXR) AND PDI>MDI AND PDI>REF(PDI,1) AND BETWEEN(ADXR,MDI,PDI) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1);
 
    {二、ADX ADXR同时上穿MDI }
 
    T2:=CROSS(ADX,MDI) AND CROSS(ADXR,MDI) AND PDI>MDI;
 
    {-----------------【图解模板】---------------------}
 
    {各线}
 
    PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),PDI),COLORRED;
 
    PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),MDI),COLORCYAN;
 
    PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),ADX),COLORWHITE;
 
    PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),ADXR),COLORYELLOW;
 
    {信号}
 
    DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&T1,ADXR,6),ALIGN,PXDN8;//关注
 
    DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&T2,MDI,10);//关注
 
    {PDI;MDI金叉ADX>20}
 
    DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&CROSS(PDI,MDI)&&ADX>20,MDI,4),ALIGN,PXDN8;//第一次跟进的机会
 
    {ADX,ADXR金叉返身向上}
 
    DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&PDI>MDI&&ADX>40&&CROSS(ADX,ADXR),ADXR,8),ALIGN,PXDN8;//最后跟进的机会
 
    {}
 
    DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&PDI>MDI&&ADXR>50&&CROSS(ADXR,ADX)&&PDI<ref(PDI,1),ADXR,12),ALIGN,PXDN8;//谨慎

飞狐我傻瓜我怕谁指标公式
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告