金字塔经典K线形态交易系统

时间:2019-11-23 16:15:46 来源:金字塔公式 作者:金字塔经典K线形态交易系统

    以下是金字塔经典K线形态交易系统(无源码的请下载附件导入)
 
    1、如果 出现黄昏之星、黄昏十字星、平顶、乌云盖顶、穿头破脚(阴线穿阳) 就开空。
 
    开空后有三种情况
 
    一、一个实体比一个实体低不区分颜色 就继续持有
 
    二、出现早晨之星、早晨十字星、平底、曙光初现、穿头破脚(阳线穿阴) 就平空开多
 
    三、如果一直是一个实体比一个实体低到14.55分平仓
 
    如果 出现早晨之星、早晨十字星、平底、曙光初现、穿头破脚(阳线穿阴) 就开多。
 
    开多后也有三种可能
 
    一、一个实体比一个实体高不区分颜色 就继续持有
 
    二、出现黄昏之星、黄昏十字星、平顶、乌云盖顶、穿头破脚(阴线穿阳) 就平多开空
 
    三、如果一直是一个实体比一个实体高到14.55分平仓
 
    开盘后先出现1的条件就执行1。  先出现2的条件就执行2.。
 
    金字塔公式 金字塔模型策略源码:
 
    input:N(41,3,100,1);
 
    早晨之星:= REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
 
    早晨十字星:= REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
 
    平底:=ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001;
 
    曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
 
    阳线穿阴:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1);
 
    黄昏之星:= REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
 
    黄昏十字星:= REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
 
    平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
 
    乌云盖顶:= REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
 
    阴线穿阳:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
 
    cond1:=黄昏之星 or 黄昏之星 or 平顶 or 乌云盖顶 or 阴线穿阳;
 
    cond2:=早晨之星 or 早晨十字星 or 平底 or 曙光初现 or 阳线穿阴;
 
    if cond1 and time <145500 then
 
    begin
 
    if holding=0 then buyshort(1,1,market);
 
    if holding>0 and enterbars>N then
 
    begin
 
    sell(1,0,market);
 
    buyshort(1,1,market);
 
    end
 
    end
 
    if cond2 and time <145500 then
 
    begin
 
    if holding=0 then buy(1,1,market);
 
    if holding<0  and enterbars>N then
 
    begin
 
    sellshort(1,0,market);
 
    buy(1,1,market);
 
    end
 
    end
 
    if time>145500 then
 
    begin
 
    sell(holding>0,0,market);
 
    sell(holding<0,0,market);
 
    end
 
    复制上述代码粘贴到到公式管理器
 
    源码解析:
 
    输出INPUT:N(41,3,100,1)
 
    早晨之星赋值: 2日前的收盘价/2日前的开盘价 < 0.95 AND 昨日开盘价 < 2日前的收盘价 AND 昨日开盘价-昨收的绝对值/昨收<0.03 AND 收盘价/开盘价>1.05 AND 收盘价>2日前的收盘价
 
    早晨十字星赋值: 2日前的收盘价/2日前的开盘价 < 0.95 AND 昨日开盘价 < 2日前的收盘价 AND 昨日开盘价=昨收 AND 收盘价/开盘价>1.05 AND 收盘价>2日前的收盘价
 
    平底赋值:最低价-昨日最低价的绝对值/最低价<0.001 AND 昨日最低价-2日前的最低价的绝对值/昨日最低价<=0.001
 
    曙光初现赋值:昨收/昨日开盘价<0.97 AND 收盘价/开盘价>1.03 AND 开盘价<昨收 AND 收盘价>昨收
 
    阳线穿阴赋值:昨收/昨日开盘价>1.03 AND 收盘价/开盘价<0.96 AND 收盘价<昨日开盘价 AND 开盘价>昨收
 
    黄昏之星赋值: 2日前的收盘价/2日前的开盘价 > 1.03 AND 昨日开盘价 > 2日前的收盘价 AND 昨日开盘价-昨收的绝对值/昨收<0.02 AND 收盘价/开盘价<0.97 AND 收盘价<2日前的收盘价
 
    黄昏十字星赋值: 2日前的收盘价/2日前的开盘价 > 1.05 AND 昨日开盘价 > 2日前的收盘价 AND 昨日开盘价=昨收 AND 收盘价/开盘价<0.95 AND 收盘价<2日前的收盘价
 
    平顶赋值:最高价-昨日最高价的绝对值/最高价<0.001
 
    乌云盖顶赋值: 昨收/昨日开盘价>1.03 AND 收盘价/开盘价<0.97 AND 开盘价>昨收 AND 收盘价<昨收
 
    阴线穿阳赋值:昨收/昨日开盘价<0.97 AND 收盘价/开盘价>1.04 AND 收盘价>昨日开盘价 AND 开盘价<昨收
 
    COND1赋值:黄昏之星 OR 黄昏之星 OR 平顶 OR 乌云盖顶 OR 阴线穿阳
 
    COND2赋值:早晨之星 OR 早晨十字星 OR 平底 OR 曙光初现 OR 阳线穿阴
 
    逻辑判断 COND1 AND 时间 <145500 THENBEGIN 逻辑判断 HOLDING=0 THEN BUYSHORT(1,1,MARKET)
 
    逻辑判断 HOLDING>0 AND ENTERBARS>N THEN   BEGIN    SELL(1,0,MARKET)
 
    BUYSHORT(1,1,MARKET)
 
    ENDENDIF COND2 AND 时间 <145500 THENBEGIN 逻辑判断 HOLDING=0 THEN BUY(1,1,MARKET)
 
    逻辑判断 HOLDING<0  AND ENTERBARS>N THEN   BEGIN    SELLSHORT(1,0,MARKET)
 
    BUY(1,1,MARKET)
 
    ENDENDIF 时间>145500 THENBEGIN SELL(HOLDING>0,0,MARKET)
 
    SELL(HOLDING<0,0,MARKET)

金字塔经典K线形态交易系统
 
    END
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告