金字塔cys股票交易模型源码

时间:2020-02-10 23:02:46 来源:金字塔公式 作者:金字塔cys股票交易模型源码

    以下是金字塔cys股票交易模型源码(无源码的请下载附件导入)
 
    金字塔公式 金字塔模型策略源码:
 
    input:m1(5,0,13,1),m2(13,12,34,1),n1(34,33,65,1);
 
    重心:AMOUNT/VOL/100,POINTDOT,COLORWHITE;
 
    STICKLINE(1 ,重心 ,重心 ,1 ,1 ),COLORYELLOW;
 
    {成本线}
 
    P0:=152;
 
    P1:=m1;
 
    P2:=m2;
 
    P3:=n1;
 
    JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
 
    DDD:=(DYNAINFO(5)<0.01 OR DYNAINFO(6)<0.01);
 
    JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) AND JJJ>(DYNAINFO(6)-0.01)));
 
    CYC5:IF(JJJT,0.01*EMA(AMOUNT,P1)/EMA(VOL,P1),EMA((HIGH+LOW+CLOSE)/3,P1));
 
    CYC13:IF(JJJT,0.01*EMA(AMOUNT,P2)/EMA(VOL,P2),EMA((HIGH+LOW+CLOSE)/3,P2));
 
    //CYC34:IF(JJJT,0.01*EMA(AMOUNT,P3)/EMA(VOL,P3),EMA((HIGH+LOW+CLOSE)/3,P3));
 
    //CYC生命:IF(JJJT,0.01*EMA(AMOUNT,P3)/EMA(VOL,P3),EMA((HIGH+LOW+CLOSE)/3,P3)),COLORRED,LINETHICK2;
 
    //CYC∞:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120)),COLORGREEN;
 
    //天:COST(99),POINTDOT,COLORWHITE;
 
    //地:COST(1),POINTDOT,COLORYELLOW;
 
    //
 
    //LC:=REF(CLOSE,1);
 
    //RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
 
    //FF:=EMA(CLOSE,3);
 
    //MA15:=EMA(CLOSE,21);
 
    //DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),\'底背离\'),COLOR0000FF;
 
    //DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),\'顶背离\'),COLOR00FFFF;
 
    //
 
    //地价:ABS((地-C)/C*100),NODRAW;{收盘价格对应筹码底部价格的百分比,取绝对值};
 
    //天地差:(天-地)/地*100,NODRAW;
 
    //底背离:CROSS(FF,MA15),NODRAW;
 
    ENTERLONG:CROSS(CYC5,CYC13) ,tfilter;
 
    EXITLONG: CROSS(CYC13,CYC5) ,tfilter;
 
    //ENTERSHORT: CROSS(C34,∞);
 
    //EXITSHORT: CROSS(∞,C34)
 
    复制上述代码粘贴到到公式管理器
 
    源码解析:
 
    输出INPUT:M1(5,0,13,1),M2(13,12,34,1),N1(34,33,65,1)
 
    输出重心:成交额(元)/成交量(手)/100,POINTDOT,画白色
 
    当满足条件1时,在重心和重心位置之间画柱状线,宽度为1,1不为0则画空心柱.,画黄色
 
    P0赋值:152
 
    P1赋值:M1
 
    P2赋值:M2
 
    P3赋值:N1
 
    JJJ赋值:如果总手>0.01,返回0.01*总成交金额/总手,否则返回前收盘价
 
    DDD赋值:(最高<0.01 OR 最低<0.01)
 
    JJJT赋值:如果DDD,返回1,否则返回(JJJ<(最高+0.01)ANDJJJ>(最低-0.01))
 
    输出CYC5:如果JJJT,返回0.01*成交额(元)的P1日指数移动平均/成交量(手)的P1日指数移动平均,否则返回(最高价+最低价+收盘价)/3的P1日指数移动平均
 
    输出CYC13:如果JJJT,返回0.01*成交额(元)的P2日指数移动平均/成交量(手)的P2日指数移动平均,否则返回(最高价+最低价+收盘价)/3的P2日指数移动平均
 
    输出//CYC34:如果JJJT,返回0.01*成交额(元)的P3日指数移动平均/成交量(手)的P3日指数移动平均,否则返回(最高价+最低价+收盘价)/3的P3日指数移动平均
 
    输出//CYC生命:如果JJJT,返回0.01*成交额(元)的P3日指数移动平均/成交量(手)的P3日指数移动平均,否则返回(最高价+最低价+收盘价)/3的P3日指数移动平均,画红色,线宽为2
 
    输出//CYC∞:如果JJJT,返回以100*成交量(手)/流通股本(股)为权重成交额(元)/(100*成交量(手))的动态移动平均,否则返回(最高价+最低价+收盘价)/3的120日指数移动平均,画绿色
 
    输出//天:获利盘为99%的成本分布,POINTDOT,画白色
 
    输出//地:获利盘为1%的成本分布,POINTDOT,画黄色
 
    LC赋值:昨收
 
    RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
 
    FF赋值:收盘价的3日指数移动平均
 
    MA15赋值:收盘价的21日指数移动平均
 
    //当满足条件FF上穿MA15时,在(最低价*0.99)位置书写文字,COLOR0000FF
 
    //当满足条件88上穿RSI时,在(最高价*1.02)位置书写文字,COLOR00FFFF
 
    输出////地价:(地-收盘价)/收盘价*100的绝对值,NODRAW
 
    输出//天地差:(天-地)/地*100,NODRAW
 
    输出//底背离:FF上穿MA15,NODRAW
 
    多头买入:CYC5上穿CYC13 ,交易信号过滤
 
    多头卖出: CYC13上穿CYC5 ,交易信号过滤
 
    空头卖出: C34上穿∞
 
    空头买入: ∞上穿C34

金字塔cys股票交易模型源码
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告