通达信御览图主图指标公式

时间:2019-10-25 23:48:54 来源:通达信公式 作者:通达信御览图主图指标公式

    以下是通达信御览图主图指标公式
 
    中点:(H+L)/2,NODRAW;
 
    OK1:=BARSLAST(L=LLV(L,360))+1;
 
    OK2:=REF(L,OK1);
 
    日360最低:=IF(CURRBARSCOUNT<=CONST(OK1+1),CONST(IF(OK1,OK2,OK2)),DRAWNULL)COLORGREEN;
 
    OK6:=IF(CURRBARSCOUNT<=CONST(OK1),CONST(IF(OK1,OK1,OK1)),DRAWNULL);
 
    月开:=O#MONTH;
 
    月高:H#MONTH,NODRAW,COLORRED;
 
    月中:(H#MONTH+L#MONTH)/2,NODRAW,COLORYELLOW;
 
    月低:L#MONTH,NODRAW,COLORGREEN;
 
    月收:=C#MONTH;
 
    STICKLINE(OK6&&月收>=月开,月高,月低,3.2,-1),COLORRED;
 
    STICKLINE(OK6&&月收<=月开,月高,月低,3.2,-1),COLORCYAN;
 
    周开:=O#WEEK;
 
    周高:H#WEEK,NODRAW,COLORRED;
 
    周中:(H#WEEK+L#WEEK)/2,NODRAW,COLORYELLOW;
 
    周低:L#WEEK,NODRAW,COLORGREEN;
 
    周收:=C#WEEK;
 
    STICKLINE(OK6&&周收>=周开,周高,周低,4.1,0),COLORFF0098;{COLORFF0098}
 
    STICKLINE(OK6&&周收<=周开,周高,周低,4.1,0),COLOR006000;{COLOR006000}
 
    DRAWKLINE(H,O,L,C);{K线}
 
    STICKLINE(O>C,C,O,3,1),COLOR00CC00;
 
    O5:=OK6&&O<C;
 
    STICKLINE(O5,C,O,3.03,0),COLOR450099;{红}
 
    STICKLINE(O5,C,O,2.5,0),COLOR4500AA;
 
    STICKLINE(O5,C,O,2,0),COLOR4500BB;
 
    STICKLINE(O5,C,O,1.5,0),COLOR4500CC;
 
    STICKLINE(O5,C,O,1,0),COLOR4500DD;
 
    STICKLINE(O5,C,O,0.5,0),COLOR4500EE;
 
    STICKLINE(O5,C,O,0.1,0),COLOR4500FF;
 
    O2:=OK6&&O>C;
 
    STICKLINE(O2,C,O,3.03,0),COLOR009900;{绿}
 
    STICKLINE(O2,C,O,2.5,0),COLOR00AA00;
 
    STICKLINE(O2,C,O,2,0),COLOR00BB00;
 
    STICKLINE(O2,C,O,1.5,0),COLOR00CC00;
 
    STICKLINE(O2,C,O,1,0),COLOR00DD00;
 
    STICKLINE(O2,C,O,0.5,0),COLOR00EE00;
 
    STICKLINE(O2,C,O,0.1,0),COLOR00FF00;
 
    STICKLINE(中点,中点,中点,0.01,1),COLOR00FFFF;
 
    HHH:=STICKLINE(周中,周中,周中,4.1,0),COLORCYAN;
 
    Q1:=STICKLINE(月中,月中,月中,4.1,-1),COLORYELLOW;
 
    STICKLINE(OK6&&周中,周中,周中,4.1,-1),COLORYELLOW;
 
    K8:=BARSLAST(EMA(C,5)>=EMA(C,20));
 
    K9:=BARSLAST(EMA(C,5)<=EMA(C,20));
 
    K110:=IF(EMA(C,5)>=EMA(C,20),(EMA(C,5)+EMA(C,20))/2,DRAWNULL);
 
    K115:=IF(EMA(C,5)>=EMA(C,20),EMA(C,5),DRAWNULL);
 
    K120:=IF(EMA(C,5)>=EMA(C,20),EMA(C,20),DRAWNULL);
 
    线5:IF(CURRBARSCOUNT<CONST(K9+2),K115,DRAWNULL)COLORYELLOW;
 
    线10:IF(CURRBARSCOUNT<CONST(K9+2),K110,DRAWNULL),COLORYELLOW;
 
    线20:IF(CURRBARSCOUNT<CONST(K9+2),K120,DRAWNULL),COLORYELLOW;
 
    立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);
 
    雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
 
    惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);
 
    春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
 
    清明:=FILTER(MONTH=4 AND (DAY=3 OR DAY=6 ),2);
 
    谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
 
    立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);
 
    小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
 
    芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);
 
    夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
 
    小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);
 
    大暑:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
 
    立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);
 
    处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
 
    白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);
 
    秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
 
    寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);
 
    霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
 
    立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);
 
    小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
 
    大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);
 
    冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
 
    小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);
 
    大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
 
    OK7:=IF(CURRBARSCOUNT<=CONST(4),CONST(IF(4,4,4)),DRAWNULL);
 
    DRAWTEXT(OK7&&立春,L/1.003,'立');
 
    DRAWTEXT(OK7&&立春,L/1.008,'春');
 
    DRAWTEXT(OK7&&雨水,L/1.003,'雨');
 
    DRAWTEXT(OK7&&雨水,L/1.008,'水');
 
    DRAWTEXT(OK7&&惊蛰,L/1.003,'惊');
 
    DRAWTEXT(OK7&&惊蛰,L/1.008,'蛰');
 
    DRAWTEXT(OK7&&春分,L/1.003,'春');
 
    DRAWTEXT(OK7&&春分,L/1.008,'分');
 
    DRAWTEXT(OK7&&清明,L/1.003,'清');
 
    DRAWTEXT(OK7&&清明,L/1.008,'明');
 
    DRAWTEXT(OK7&&谷雨,L/1.003,'谷');
 
    DRAWTEXT(OK7&&谷雨,L/1.008,'雨');
 
    DRAWTEXT(OK7&&立夏,L/1.003,'立');
 
    DRAWTEXT(OK7&&立夏,L/1.008,'夏');
 
    DRAWTEXT(OK7&&小满,L/1.003,'小');
 
    DRAWTEXT(OK7&&小满,L/1.008,'满');
 
    DRAWTEXT(OK7&&芒种,L/1.003,'芒');
 
    DRAWTEXT(OK7&&芒种,L/1.008,'种');
 
    DRAWTEXT(OK7&&夏至,L/1.003,'夏');
 
    DRAWTEXT(OK7&&夏至,L/1.008,'至');
 
    DRAWTEXT(OK7&&小暑,L/1.003,'小');
 
    DRAWTEXT(OK7&&小暑,L/1.008,'暑');
 
    DRAWTEXT(OK7&&大暑,L/1.003,'大');
 
    DRAWTEXT(OK7&&大暑,L/1.008,'暑');
 
    DRAWTEXT(OK7&&立秋,L/1.003,'立');
 
    DRAWTEXT(OK7&&立秋,L/1.008,'秋');
 
    DRAWTEXT(OK7&&处暑,L/1.003,'处');
 
    DRAWTEXT(OK7&&处暑,L/1.008,'暑');
 
    DRAWTEXT(OK7&&白露,L/1.003,'白');
 
    DRAWTEXT(OK7&&白露,L/1.008,'露');
 
    DRAWTEXT(OK7&&秋分,L/1.003,'秋');
 
    DRAWTEXT(OK7&&秋分,L/1.008,'分');
 
    DRAWTEXT(OK7&&寒露,L/1.003,'寒');
 
    DRAWTEXT(OK7&&寒露,L/1.008,'露');
 
    DRAWTEXT(OK7&&霜降,L/1.003,'霜');
 
    DRAWTEXT(OK7&&霜降,L/1.008,'降');
 
    DRAWTEXT(OK7&&立冬,L/1.003,'立');
 
    DRAWTEXT(OK7&&立冬,L/1.008,'冬');
 
    DRAWTEXT(OK7&&小雪,L/1.003,'小');
 
    DRAWTEXT(OK7&&小雪,L/1.008,'雪');
 
    DRAWTEXT(OK7&&大雪,L/1.003,'大');
 
    DRAWTEXT(OK7&&大雪,L/1.008,'雪');
 
    DRAWTEXT(OK7&&冬至,L/1.003,'冬');
 
    DRAWTEXT(OK7&&冬至,L/1.008,'至');
 
    DRAWTEXT(OK7&&小寒,L/1.003,'小');
 
    DRAWTEXT(OK7&&小寒,L/1.008,'寒');
 
    DRAWTEXT(OK7&&大寒,L/1.003,'大');
 
    DRAWTEXT(OK7&&大寒,L/1.008,'寒');

通达信御览图主图指标公式
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告