通达信原始人毁三观指标公式

时间:2019-11-02 15:35:01 来源:通达信公式 作者:通达信原始人毁三观指标公式

    以下是通达信原始人毁三观指标公式
 
    {常规条件}
 
    常规条件A:=((EXIST(CLOSE/REF(CLOSE,1)>1.095 AND CLOSE=HIGH,13) OR EXIST(((CLOSE-LLV(CLOSE,5))/LLV(CLOSE,5)*100)>10,13))) AND HHV(HIGH,34)!=HIGH;
 
    常规条件B:=IF(BARSTATUS=2,VOL/FROMOPEN>(REF(VOL,1)+REF(VOL,2))/480,VOL>(REF(VOL,1)+REF(VOL,2))/2);
 
    {毁三观指标}
 
    DD:=BARSLAST(DOPEN=REF(DOPEN,1) AND DHIGH=REF(DHIGH,1) AND DLOW=REF(DLOW,1) AND DCLOSE=REF(DCLOSE,1));
 
    DDT1:=BARSLAST(DD=1);
 
    现波段重心:SUM(AMOUNT,DDT1+1)/SUM(VOL,DDT1+1)/100,NODRAW;
 
    前波段重心:REF(现波段重心,DDT1+1),NODRAW;
 
    前2波段重心:REF(前波段重心,DDT1+1),NODRAW;
 
    前3波:=REF(前2波段重心,DDT1+1);
 
    前4波:=REF(前3波,DDT1+1);
 
    前5波:=REF(前4波,DDT1+1);
 
    前6波:=REF(前5波,DDT1+1);
 
    前7波:=REF(前6波,DDT1+1);
 
    波段MAX:=MAX(前波段重心,MAX(前2波段重心,MAX(前3波,MAX(前4波,MAX(前5波,MAX(前6波,前7波))))));
 
    BB1:=波段MAX=前波段重心;
 
    BB2:=波段MAX=前2波段重心;
 
    BB3:=波段MAX=前3波;
 
    BB4:=波段MAX=前4波;
 
    BB5:=波段MAX=前5波;
 
    BB6:=波段MAX=前6波;
 
    BB7:=波段MAX=前7波;
 
    AA1:=IF(BB1=1,0,前波段重心);
 
    AA2:=IF(BB2=1,0,前2波段重心);
 
    AA3:=IF(BB3=1,0,前3波);
 
    AA4:=IF(BB4=1,0,前4波);
 
    AA5:=IF(BB5=1,0,前5波);
 
    AA6:=IF(BB6=1,0,前6波);
 
    AA7:=IF(BB7=1,0,前7波);
 
    波段MAX2:=MAX(AA1,MAX(AA2,MAX(AA3,MAX(AA4,MAX(AA5,MAX(AA6,AA7))))));
 
    波段MIN:=MIN(前波段重心,MIN(前2波段重心,MIN(前3波,前4波)));
 
    波段趋势:=(((前波段重心>前2波段重心)+(前2波段重心>前3波)+(前3波>前4波))>=2 AND DLOW>波段MIN) OR DHIGH>波段MAX2;
 
    快速K线:=HIGH>波段MAX2;
 
    {指标预警}
 
    D条件A:=CLOSE>OPEN AND DCLOSE>DOPEN AND 波段趋势=1 AND 快速K线 AND (EXIST(DCLOSE<DOPEN,4) OR EXIST(CLOSE<OPEN,4)) AND 常规条件A AND 常规条件B;
 
    D条件B:=(DCLOSE-REF(CLOSE,4))/REF(CLOSE,4)*100;
 
    预警X: D条件A OR CROSS(D条件B,20),COLORYELLOW,NODRAW;
 
    {画图}
 
    DRAWKLINE(DHIGH,DOPEN,DLOW,DCLOSE);
 
    STICKLINE(波段趋势=1,前波段重心,前波段重心,10,0),COLORYELLOW;
 
    DRAWTEXT(D条件A OR CROSS(D条件B,20),DLOW*0.97,'↖买入 '),COLORYELLOW;

通达信原始人毁三观指标公式
相关阅读

Related read

热门推荐

网站地图 l 最新文章

股票怎么玩?589股票学习网,提供从零开始学炒股书籍在线阅读,归类于股票入门基础知识大全

声明:本站文章均来自互联网,不代表本站观点,如有异议,请与本站联系,本站为非赢利性网站 不接受任何赞助和广告